Privacy Policy

Mini corso Excel: parte 4 – formule con E, O, NON

----------------Sponsor----------------

----------------Sponsor----------------

Proseguiamo con questo mini corso Excel che pare stia facendo comodo a molti.

Oggi vorrei parlare del funzionamento degli operatori E, O, NON all’interno delle formule con il SE.

Per il funzionamento delle formule con il SE, vi rimando alla puntata precedente (parte 3: formule con il SE).

I tre operatori: E, O, NON, ci consentono di ampliare il ventaglio delle possibilità offerte dall’operatore SE.

Normalmente le formule con il SE vengono utilizzate in accoppiata con gli operatori di uguaglianza ( = ), oppure con gli operatori > e < (maggiore e minore). Utilizzare anche gli operatori E, O, e NON, ci consentirà di avere ancora più flessibilità nelle formule.

Vediamoli in dettaglio.

L’operatore E.

Questo operatore ci consente, all’interno di una formula SE, di dire ad excel che una determinata condizione è verificata solo se si verificano contemporaneamente due o più condizioni.

Vediamo come si presenta la struttura di una formula SE con operatore E:

=SE(E(cella1=”condizioneA”;cella2=”condizioneB”);
allora_fai_così;altrimenti_fai_cosà)

Vediamo che la E va sempre messa all’interno della condizione di “test” del SE.

In sostanza stiamo dicendo ad Excel che, SE nella cella1 si verifica la condizione A, e contemporaneamente si verifica nella cella 2 la condizione B, allora nella cella che contiene la formula deve scrivere un certo valore, altrimenti ne scriverà un altro.

Un semplice esempio:

Mi si perdoni la poca fantasia, quando si parla di fogli di calcolo mi è difficile essere creativo :-)

Nel nostro foglio abbiamo tre colonne:

Nome della casa; Vista Mare SI/NO; Giardino SI/NO

Nella colonna D vogliamo far desumere ad Excel, sulla base dei dati presenti, se il valore della casa è alto oppure no.

Nella formula che vedete nell’esempio ho scritto:

=SE(E(nella cella B2 c’e’ scritto SI e nella cella C2 c’è scritto SI)allora scrivi Alto, altrimenti non scrivere nulla)

Con la sintassi giusta si ha: =SE(E(B2=”SI”;C2=”SI”);”Alto”;””)

Le virgolette dopo “Alto” ( “” ) (aperte e chiuse virgolette) dicono ad Excel di non scrivere nulla.


Il risultato è ovviamente:

Complichiamo la formula e diciamo ad excel che, se la casa non ha giardino nè vista mare, il valore sarà basso, se ha solo vista mare o solo giardino il valore sarà medio.

Scriveremo quindi:

La formula è ben più complicata perchè dobbiamo aggiungere, oltre al SE e all’ E, anche l’ O.

L’operatore O dice ad Excel che una determinata condizione è verificata se O una O l’altra condizione sono verificate (anche non contemporaneamente, è questo che lo differenzia dall’E).

La formula è:

=SE(E(B2=”SI”;C2=”SI”);”Alto”;
SE(O(E(B2=”SI”;C2=”NO”);E(B2=”NO”;C2=”SI”));”Medio”;“Basso”))

Che vuol dire:

Prima condizione

Se nella cella B2 c’è scritto SI, e nella cella C2 c’e’ scritto SI ; allora scrivi Alto

altrimenti, Seconda condizione

SE nella cella B2 c’è scritto SI e nella C2 c’è scritto NO

OPPURE (è l’operatore O)

nella cella B2 c’è scritto No e nella C2 c’è scritto SI ; allora scrivi Medio

altrimenti, Terza condizione

se nessuna delle precedenti combinazioni si verifica (il che vuol dire che nelle due celle ci sarà sicuramente scritto NO e NO ), scrivi “Basso”.

Il risultato è ovviamente:

Per raggiungere lo stesso risultato avremmo potuto anche utilizzare l’operatore NON.

Questo operatore dice ad Excel che se in una data cella NON c’è scritto un dato valore, allora la formula dovrà scrivere una determinata cosa.

Utilizzare l’operatore NON con l’esempio precedente è un po’ contro-intuitivo (perchè si tratta di affermazioni/negazioni che complicherebbero troppo). Cambiamo quindi la struttura dei dati per far capire meglio.

Nella prima colonna abbiamo sempre il nome della casa, nella seconda colonna avremo la prima caratteristica della casa, nella terza colonna avremo un’altra caratteristica e nella quarta la nostra formula che stimerà il valore della casa.

La formula è:

=SE(E(NON(B2=”Giardino”);NON(C2=”Vista Mare”));

“Basso”;SE(E(NON(B2=”Giardino”);C2=”Vista Mare”);”Medio”;“alto”))


E dice:

Prima condizione

Se nelle celle B2 e C2 non c’e’ scritto nè “Giardino” nè “Vista Mare”;

allora scrivi “Basso”;

Altrimenti, seconda condizione

Se nella cella B2 non c’è scritto giardino ma nella cella C2 c’è scritto vista mare,

allora scrivi medio;

Atrimenti, terza condizione

se non si verificano le precedenti condizioni, scrivi “alto”

Chiaramente questo esatta formula non tiene conto di altri possibili valori che potrebbero assumere le celle nelle colonne “caratteristica 1″ e “caratteristica 2″, per cui nella vita reale difficilmente vi capiterà una situazione del genere: una semplificazione però era necessaria per spiegare meglio come funzionano i vari operatori.

E’ chiaro che, come tutte le formule di Excel, queste vi saranno utilissime nel caso doveste avere molti dati da elaborare (non certo tre righe come quelle dell’esempio). Vi faranno risparmiare davvero molto tempo.

Spero che questa guida possa aver fatto comodo a qualcuno.

Al prossimo articolo,

Gorilla

Be Sociable, Share!

Ti è piaciuto l'articolo? Vota Ok oppure No. Grazie Mille!

Puoi votare l'articolo anche qui, gli articoli precedenti qui.
  1. avatar
    • Eustachio Santochirico
    • febbraio 26th, 2011

    Utilissimo!! dove posso trovare altro materiale analogo? …operatori: Concatena, $, test, val, ecc.
    Grazie Mille

  2. avatar

    @Eustachio Santochirico

    Grazie mille !

    Tutte le guide sono pubblicate sul blog… nel caso ne dovessi fare altre avvertirò !

  3. avatar
    • Mariateresa
    • marzo 22nd, 2012

    Grazie per aver spiegato in modo semplicissimo un argomento alquanto articolato.
    Questo dovrebbe essere il modo di fare di chi vuol insegnare!

  4. avatar
    • filippo
    • dicembre 7th, 2012

    mi scrivete la sintassi per favore per la seguenti 4 condizioni..

    se a=”v” e b<3 risultato 100
    se a="v" e b=3 risultato 200
    se a="p" e b=3 risultato 300
    se a="p" e b<3 risultato 400

    grazie anticipatamente.

  5. avatar

    Buongiorno a tutti. Ho bisogno di un aiuto, dopo che per girni mi sto picchiando son la funzione se.
    Praticamente avrei bisogno di inserire una funzione che mi dia questo tipo di risultato:
    data del giorno 25/02/13

    01-mar-13 ven 75
    02-mar-13 sab 75
    03-mar-13 dom 75
    04-mar-13 lun 75

    per ogni giorno della settimana se la differenza con la data odierna è inferiore a 7 deve sscrivermi 100 altrimenti 75. Queseto l’ho fatto senza problemi. Però se la differenza è minore di 7 e il giorno della settimana è ven / sab /dom deve scrivermi 75
    Bisogna combinare la funzione e / o ma non ci riesco.
    Qualcuno riesce ad aiutarmi?
    Grazie

  6. avatar

    @MAURO

    Ciao Mauro, questa dovrebbe andare:

    Dove in B3 hai la differenza tra le due date, ed in C3 hai il tipo di giorno (ven, sab, lun, ecc)

    =SE(E(B3<7;O(C3=”ven”;C3=”sab”; C3=”dom”));100;75)

    Saluto!

    Gorilla

  7. avatar
    • alberto
    • marzo 4th, 2014

    grazie, è stato reso molto semplice e chiaro un argomento alquanto complesso

  1. No trackbacks yet.

Privacy Policy