Privacy Policy

Mini corso di Excel: parte 3 – formule con il SE

----------------Sponsor----------------

----------------Sponsor----------------

excel

E siamo arrivati alla terza puntata di questo mini corso di Excel. Oggi vorrei affrontare un tema davvero importante, se non fondamentale: le forumle che utilizzano l’operatore logico SE .

Iniziamo dall’operatore SE. Cosa possiamo farci ?

Una premessa importante: l’esempio che segue è semplificato per poter fornire una spiegazione comprensibile. Nella realtà non vi capirerà di avere situazioni così semplici, ma spesso dovrete fare i conti con una quantità di dati molto più imponente. Ed è qui che l’uso dell formule dà il meglio di sè: consente di automatizzare processi che altrimenti risulterebbero impossibili da effettuare manualmente.

L’operatore SE, utilizzato in una formula, ci consente di far fare ed Excel una determinata operazione al verificarsi di un particolare evento. In particolare consente di “scrivere” il contenuto di una cella, in funzione delle variabili che gli abbiamo dato in pasto.

Vediamo la struttura della formula:

=se(test;se_vero;se_falso)

che significa

=se(succede_questo;allora_fai_così;altrimenti_fai_cosà)

Prendiamo un facile esempio. Immaginiamo di avere un foglio di excel così strutturato

excel_formula_se_1

Diciamo che, sulla base dell’età delle persone, vogliamo far scrivere ad Excel, sulla colonna appena a destra della ” B “, se una persona è “giovane”, oppure no.

Utilizziamo l’operatore SE, e scriviamo la seguente fomula, posizionandoci nella cella C2:

=SE(B2<18;”Giovane”;0)

che significa:

SE nella cella B2 (quella che contiene il dato sull’età della persona) il valore è inferiore a 18, allora scrivi “Giovane”, altrimenti scrivi ” 0 ” (zero).

Copiamo la foruma (control + c) e incolliamola anche nelle celle sottostanti (control + v).

Nota: per far “scrivere” ad excel un valore, occorre, all’interno della forumula, inserire il testo da far scrivere tra le virgolette ” “.

Il risultato della formula sarà ovviamente questo:

excel_formula_se_2


Vediamo però che, se nella cella di fianco alla persona con età 15 avremo il valore “Giovane”, negli altri casi Excel ha correttamente scritto il valore “0” (zero), come da noi specificato.

Complichiamo un po’ le cose. Diciamo ad excel che vogliamo che, quando l’età è maggiore di 18 anni, ci scriva il valore “anziano”. La formula sarà:

=SE(B2<18;”Giovane”;”Anziano”)

Come si può notare, abbiamo detto ad Excel che, in caso trovasse nella colonna B un valore inferiore a 18 deve scrivere “Giovane”, altrimenti deve scrivere “Anziano”.

Copiando la formula anche nelle celle sottostanti otterremo questo:

excel_formula_se_3

Ora complichiamo le cose ancora un po': vogliamo dire ad excel che, nel caso trovi un valore compreso tra 18 e 65, scriva “Maturo”, negli altri casi scriva o Giovane o Anziano. Vediamo come fare.

La forumula dovrà avere due componenti SE, cioè dovrà seguire questa struttura:

=se(succede_questo;allora_fai_così;se(succede_questo;allora_fai_così;
altrimenti_fai_cosà);altrimenti_fai_cosà)

Sembra molto complicato, ma non lo è poi così tanto. Vediamo la formula reale come risulterebbe.

=SE(B2<18;”Giovane”;SE(E(B2>18;B2<65);“Maturo”;”Anziano”))

Abbiamo aggiunto l’operatore ”   E   “, che ci aiuta nel precisare meglio il verificarsi di alcune condizioni.

Nell’esempio, la formula significa:

=se nella cella B2 trovi un valore inferiore a 18;allora scrivi “Giovane”;altrimenti SE nella cella B2 trovi un valore che è contemporaneamente maggiore di 18 e minore di 65;allora scrivi “Maturo”;altrimenti se non si verifica nessuna delle due condizioni precedenti (il che vuol dire che il valore sarà sicuramente superiore a 65) allora scrivi “Anziano”.

In pratica abbiamo “nidificato” un secondo SE all’interno di un SE. Excel supporta fino ad un massimo di 11 SE (se non vado errato) nidificabili. Per cui potrete arrivare a funzioni particolarmente intricate (Se succede questo;allora fai così; altrimenti se succede quest’altro; allora fai cosà;altrimenti se succede quest’altro ancora;allora fai così… eccetera eccetara)

Vediamo come risulta nella pratica:

excel_formula_se_4

Sperando che questa guida vi possa essere stata d’aiuto, vi saluto

Be Sociable, Share!

Ti è piaciuto l'articolo? Vota Ok oppure No. Grazie Mille!

Puoi votare l'articolo anche qui, gli articoli precedenti qui.
  1. avatar

    @PUNDGAZA

    Ciao Pundgaza,

    non puoi variare dinamicamente il valore di B, dovresti creare una cella D, nella quale dici: “se la somma di B+C è maggiore di A, allora in D scrivi A-C, altrimenti scrivi la somma di B+C”

    ovvero in D scriverai

    =SE( (B+C)>A;A-C;B+C)

    cioè appunto, se la somma di B+C è maggiore di A, allora in D scrivi la differenza tra A e C, altrimenti in D scrivi la somma di B+C

    Saluto!

    Gorilla

  2. avatar
    • Genzina
    • gennaio 21st, 2013

    Sono guide semplici e comprensibili, grazie mille

  3. avatar
    • carlo
    • gennaio 22nd, 2013

    devo stilare un bozza di cedolino paga con seguente problema:
    esempio :se la cella F28 il valore è superiore a 1, nella cella g28 il valore deve essere uguale a quello della cella b20, se la cella F28 il valore è inferiore a 1 non deve essere inserito nulla, cioè vuota senza carattere.
    Grazie

  4. avatar

    @carlo

    Ciao Carlo;

    in g28 scriverai

    =se(F28>1;B20;””)

    Fammi sapere se funzia!

    Gorilla

  5. avatar
    • carlo
    • gennaio 22nd, 2013

    @Gorilla
    Tutto ok. grazie. Le avevo provato tutte le formule meno quella di mettere due volte le virgolette senza spazio. Grazie ancora. ciao

  1. No trackbacks yet.

Privacy Policy